No Way, there’s a FIX for this?! Windows 7 – Resolution problem with Intel 915 – Apparently yes!

I am by no means a gadget-loving geek or an early adopter (or is is adapter?) of gadgetry. I have a tendency towards reticence when it comes to buying any kind of electronic equipment. And so it seems my eventual purchases have mostly been out of real necessity: do I need a Mac if I am doing Web development: yes. Do I need a PC if I am doing Web development:yes. Do I need a Blu-Ray DVD player so I can watch Netflix on my TV? Not really ( I did buy it for the mans birthday but I seem to be the only one who really uses it).

Anyway, enough with the preamble! I had an old Compaq PC tower(bought by the mans’ brother back in 2005) that used a new Compaq Q1859 monitor for the display (I used to have a NEC monitor then the mans bought me a widescreen HP HDMI widescreen monitor – sweet). On one side of my desk I have the Mac mini and the HP HDMI monitor – on the other side I had the elderly PC with the Q1859. I would develop my Web sites in Firefox, Chrome and Safari (Mac) and then safety-check them for cross browser support in Windows IE 6,7, 8 and other major browsers that Windows can run) on the PC. It was my simple system and it saved me from being one of those designers who never checks their sites in any other browser except the one they use because they don’t have the machine that can run it or can’t be bothered or just doesn’t think it matters – by the way, after loading my own recently re-designed site in IE8 in Windows 7 I’ve just caught some F**k-ups – yikes!

Then after about 2 days of not paying any attention to it, my PC wouldn’t turn on. It had no secondary on/off switch in the back – the power cord wasn’t the issue – an even older PC tower could use it. All of a sudden I was without a sure-fire way to check a site in IE and my client was reporting some rendering issues in IE and was kind of getting impatient … I begged for time and even though I could load the site in Chrome and basically see the same kind of issues as in IE (yet another reason to develop in Chrome, 1st) I needed to replace my PC, case closed. It’s just very distracting to lose half of your development system overnight.

After pricing refurbished Windows 7 laptops on and and reading laptop reviews on – I still really only needed a machine that could run Internet Explorer. I went on Craigslist and arranged to meet the seller of a Dell XPS M140 with Windows 7. I figured that the size of the laptop display didn’t really matter because I had the external Q1859… So I bought the Dell, took it home and plugged in my monitor. I got the VGA: No signal, Going to sleep message. I rebooted: the same message. Oops. Was this really happening? Seemed like I could not use my monitor with this laptop because of the video card driver. There’s a lot of info online about older Intel video drivers and Windows 7 and a bunch of folks unhappy with Intel for dropping them after only 3 years (or so I read on several forums) and if you research this topic you might get as discouraged as I did; it seems that there will never be an upgrade available from Intel. I was just getting used to the Dell’s 14 inch screen when I decided to look around online just one more time.

Before I did this I also ran a Windows Update since the seller had last updated in February. After I did my Devices listed the Compaq monitor, finally. Before it didn’t even recognize it existed.

Wow you are chatty. Is there a fix or not?

Well, I can’t swear it will work for everyone who has an older Intel model but the one I have is from 2006 and it worked for me.

I found this forum: Windows 7 – Resolution problem with Intel 915. I read the reassuring words of satanicdude and used TekBoi’s download link and followed InstallWizard. There was 1 minor hiccup just like I was warned about. But the driver installed the second time much like the way satanicdude said it would. I restarted Windows and saw the Windows start up screen on my Compaq Q1859. Additionally my laptop display automatically reset to 1280 x 800. Before it was stuck on a maximum resolution of 1024 x 768.

Still, everything is not perfect. My Compaq Q1859 auto detects the factory setting of a resolution of 1366 x 768 & from the Dell’s 1280 x 800 display it looks a little stretched out (but it did on my old PC) but it also doesn’t fill the monitor screen. Although at least now the Action Center no longer reports any issues with the Video Card!

Still no Aero though. But for now I am Ok.

And now I have 3 screens!

Update Re: stretched/squished screen appearance with external monitor/laptop combo.

If you also have a widescreen monitor determined to stick to a resolution that makes the desktop & Web pages look stretched or squished and/or displays pages in letterbox and not full screen, try this suggestion from our all caps loving friend. Don’t bother clicking the link at the top of the post, the YouTube video is not available.